Midnight

Midnight

Help your Mac get a good night sleep.

Download

Requirements

Requires Mac OS X version 10.4.11 or later.

Apple only officially supports safe sleep on the PowerBook G4 (Double-Layer SD) together with all of the new Intel books and desktops, so I'm afraid I'm doing the same. It is possible to 'adapt' unsupported Macs so that they can hibernate, but if you want to do that you will need to find the information somewhere else (hack). I don't recommend it and if it breaks your lovely Mac don't blame me!

If your Mac doesn't support safe sleep you can still use Midnight but the hibernation option will be disabled.
If your Mac doesn't have Airport the Airport option will be disabled.