iPlace

iPlace

Browse web pages and place images anywhere.

Download

Requirements

Requires Mac OS X version 10.4 or later.
Requires SIMBL version 0.8.1 or later.
Requires either Safari 2.0.4 or Safari 3.

iPlace is a Universal Binary application.